
 

What’s new  
To learn more about the new features and enhancements in Cornerstone* Software version 9.5:  

• After you upgrade, press F1 or click the Help  button on the toolbar. The Welcome topic in the F1 window describes the 
new major features, with links to more details. 
Note: If you do not see the Welcome topic, search for welcome in the F1 window to access the Welcome topic.  

• If you have skipped any previous upgrades, be sure to review the release notes for those upgrades, so you know about all 
the previous features and enhancements that have been incorporated into Cornerstone 9.5. 

• Take a self-guided course to discover this release's highlights, with videos, knowledge checks, and more. 

Computer hardware and software requirements  
For hardware and system requirements, see the Hardware and Operating System Guidelines. 
See recommended settings for Windows* 10 or Windows* 11.  

Security and default settings  
There are three new security settings:  

• Communication Messages (Dialog tab) 
• Communication Messages Setup (Dialog tab) 
• Appointment Audit report (Reports tab) 

 
There are eight new or updated Controls and Default settings:  

• Communication message creation: Controls > Communication Messages 
• Communication message settings: Controls > Defaults > Practice & Workstation > Messages  
• Display greater than 20 patient messages: Controls > Defaults > Practice & Workstation > Invoice 
• Inpatient check-in option and Inactive status: Controls > Reason for Visit 
• Recently accessed clients maximum setting is now 20 clients: Controls > Defaults > Practice & Workstation > Clients 
• Recently accessed patients maximum setting is now 20 patients: Controls > Defaults > Practice & Workstation > 

Patients 
• Client communication tab order on Patient Clipboard: Controls > Defaults > Staff  
• Lab printing preferences for labels and tube labels: Activities > Lab Work > Laboratories 

  

  

 

 

https://www.idexx.com/en/veterinary/support/documents-resources/cornerstone-software-resources/
https://learn.idexx.com/learn/course/6708/whats-new-with-cornerstone-95?generated_by=474117&hash=7860dfd271c1b1a1bb823fb17b60be4310ab715e
https://www.idexx.com/files/cornerstone-hw-os-guidelines.pdf
https://www.idexx.com/files/windows-10-recommended-settings.pdf
https://www.idexx.com/files/windows-11-recommended-settings.pdf
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Featured Updates 
Improving daily navigation 

• You now have direct access to recently viewed client and patient records on the primary workflow windows. The F7 and F8 
functionality has been added to frequently used windows, such as the Patient Clipboard*, Client Account, New 
Appointment, Patient Visit List, and more, Client and Patient ID fields link directly to recently accessed clients and patients, 
using the value set in the client and patient default settings (maximum of 20).  

 
Patient Clipboard with Client ID drop down 

 
Patient Visit List with Patient ID drop down 

• Say goodbye to retyping search criteria over and over when working through lists of related records. When searching for 
and updating records in the Client, Patient, and Invoice Item lists, previously selected search criteria are retained when you 
return to the list. They remain until you change the criteria or close the window.  

 

Invoice item List with retained search criteria after updating the selected item 

• You can simplify Reason for Visit lists when scheduling and checking in—by inactivating both the primary and secondary 
reasons. You can also set inpatient as the default option for primary reasons to add patients to the Whiteboard, saving a 
step at patient check-in. Update status and set the default option from Controls > Reason for Visit.  

 
 

 
 

 



3  

• Create and assign specific email/fax subjects and messages for common communications, such as invoices, estimates, 
patient history, purchase orders, and documents.  
To set up messages, use Controls > Communication messages. 
To assign a default message, use Controls > Defaults > Practice & Workstation > Messages. 

  
 

• Can’t remember which report you used last year? Are there reports you use frequently and want to access faster? Mark a 
report as a favorite with a single click, and access all favorites from the Report Search window at Reports > Find a Report. 
Spend less time searching, more time analyzing and acting.  

 
 

 
Report Search window showing selected favorites only 
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Ticking boxes with inventory: New and improved inventory workflows, 
window options, and reports 

• When you add an item to the Want List, a notice will appear if the item is on 
an order or on backorder. You can still add the item to the list.  

• The Purchasing Worklist can be filtered and viewed by location or 
classification, for both single- and multi-location inventory users. 

 

 
• The same invoice item can now be added more than once to a purchase order, for example when different quantities are 

purchased at different costs (e.g., buy 12 get 1 free) or specific quantities are earmarked for a particular client (special 
order) or inventory location (for multi-location inventory users). (This option does not apply to SmartOrder* orders.) Use a 
note to indicate whether a specific line item is intended for a specific location, since orders are placed by location group 
only.  

 
Purchase order with same item listed multiple times, demonstrating use case of quantity, UOM, and pricing options 

 

 
Purchase order with same item listed multiple times, demonstrating use of notes to identify a specific entry's purpose 

 
• The Create Purchase Order, Edit Purchase Order, and Receive Purchase Order windows can be sorted by any column. To 

sort, click the column header to toggle between ascending and descending sort order. You can also click and drag columns 
to change the display. Column order and sort selections are retained for the logged-in user. 

Classification filter Location filter 
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• The Receive Purchase Order window has two additional updates: 
1. An Extended cost column was added to improve receipt 

reconciliation, as well as to match the column choices from the Create 
and Edit Purchase Order windows. To add the column to your Receive 
Purchase Order window, right-click the column header row, select 
Columns, and then choose Extended Cost. 

2. When you manually enter a vendor receipt and save it to complete 
later, the items will be displayed in the order they were originally 
entered. 

• Inventory reports, such as the Counts and Purchase History, can now be 
filtered to include or exclude inactive items.  

Online Payments now offered with Cornerstone Payments 
Current subscribers to the Cornerstone integrated card processing solution (now called Cornerstone Payments) can also enroll for a 
new feature called Online Payments (U.S. practices only).  
Online Payments allows you to: 

• Email or text payment requests from Cornerstone to your clients, with no change to your current workflows. 
• Apply processed payments directly to the client’s account. 
• Monitor all request activity from the new Pay Online Request Log (from the Activities menu). Enrollment is required to 

display the log. 
What’s even better? 

• When sending a request as part of the invoice posting process, the invoice is automatically attached to the request.  
• The request uses the existing invoice balance or client balance to reduce entry errors by your busy team.  
• When you select Pay Online in the Post Invoice window, Apply Payments is automatically deselected to reduce steps 

your team has to remember.  

 
Ready to get started?  

• Learn more about Cornerstone Payments. 
• Enroll now in Online Payments.  

 

  

Adding the Extended Cost column to the 
Receive Purchase Order window 

Active/inactive item filter 

https://software.idexx.com/cornerstone-integrated-payments
https://software.idexx.com/cornerstone-online-payments
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General enhancements and improvements   
Appointment Scheduler and Check-in 

• Move appointments within the same day even faster with drag and drop functionality. Dragging will also auto-scroll the 
Schedule for Today window, both vertically and horizontally 

• When you inactivate a Primary Reason for Visit, a message 
will appear based on the current use of the reason:  
o Primary reasons used for currently checked-in patients 

cannot be inactivated until the patient is checked out or 
the check-in information is updated to a different 
primary reason. Tip: Use the Daily Planner Checked-in 
tab, and click the Reason for Visit column header to 
sort and locate by reason. 

o Primary reasons used for scheduling templates cannot be 
inactivated until the template(s) are updated to a 
different primary reason (Controls > Appointment 
Scheduler > Template Designs). 

o Inactivating a primary reason will remove the reason 
from the Reason for Visit List when scheduling or 
checking patients in, as well as clear the reason from any 
existing tickler file entries. Existing appointments will 
retain the primary reason for use in reports and in 
Appointment Scheduler displays until the patient is 
checked in or the appointment is updated, requiring an active primary reason. 

o When you inactivate a Secondary Reason for Visit, all existing occurrences will be converted to text format (as though 
the reason were manually typed in). The reason will be removed from the Secondary Reason for Visit List when you 
schedule or check in patients. 

• A new Appointment Audit report gives you insight into appointment and block scheduling, modifying, and deleting. Change 
records are time and date stamped, and the logged-in user and workstation data are also supplied. Security access 
required. 

• If you open the Check/out window from workflows using prepopulated client and patient information (e.g., from the 
Patient Clipboard or the Appointment window), the cursor will now be in the weight field by default. 

• Error 2 and error 6 messages are no longer displayed on the Check-in and Appointment Scheduler windows. Information is 
now logged without interrupting the user’s activities. 

• The Appointment Scheduler window will no longer briefly display a previous date upon opening to the current day. 

Documents (Medical Notes and correspondence) 
• If a document is started and then left open for an extended period of time or started on one day and then saved or closed 

on the next day, the document creation date/time will be the date/time the document was started. 
• Document attachments can be accessed and opened in the Patient Clipboard Preview pane by double-clicking the 

attachment. 
• When adding attachments to a document, you can now select multiple files 

using Ctrl or SHIFT + click in the Select File window. 
• Reduced the occurrence of “Intermittent OLE decrypt / file not found” errors 

when toggling between notes within the Patient Clipboard preview pane.  
• Error 15 messages are no longer displayed when printing documents—

information is now logged without interrupting the user’s activities.  
• Pick lists within a group code that are part of a document template will 

prompt as expected when you add the document to a patient and Perform 
the group. 
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Email/fax 
• Errors have been fixed related to Communication Log filtering from the Patient Clipboard and results-per-page display of 

data. 
• Emailing in Cornerstone with SMTP has been updated to work with more domain addresses, and we have re-enabled the 

ability to send emails using Office* Exchange SMTP settings. 

Estimates and invoices 
• When the estimate print default is set to 0, the Copies option on the Save Estimate window is displayed correctly as 0, and 

the print dialog will not be displayed. 

 
 

• You can now opt to not have the greater-than-20-patients message be displayed when invoicing clients. Change the setting 
under the Invoice default settings (Controls > Practice and Workstation > Invoice). 

 
 

• Error 2 and error 6 messages are  no longer displayed when printing estimates and invoicing patients with multiple alerts. 
Information is now logged without interrupting the user’s activity.  

• Online Payments subscribers: When you select Pay Online in the Post Invoice window, Apply Payments is automatically 
deselected to reduce steps your team has to remember. 

Imaging 
• Made improvements to the handling of image sizes and the number of images when importing images into Cornerstone to 

reduce the risk of Cornerstone crashing. In cases where the number and size of images being imported cannot be managed 
as presented, a message will be displayed. 

• New imaging cases can be successfully created from both the Patient Clipboard and Image Explorer workflows, regardless 
of email configuration settings. 

• Improved IDEXX Web PACS* patient matching to avoid creating duplicate patients when taking images without a request. 

Inventory   
• Want List 

o Switching between Inventory Item and Not an inventory Item on the want list will clear any location or location 
group entries. 

o The Save changes message will be displayed when you click Cancel, for consistency with other inventory windows. 
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• Purchasing Work List and creating Purchase Orders 
o You can now create more than two open orders when starting purchase orders from the Purchasing Work List. 
o Adding an item to the Want List and choosing a location will populate both the Location and Location group columns 

on the Purchasing Work List (multi-location inventory). 
o When adding additional items to placed orders, the on-order quantity is displayed correctly in item information 

windows and on order/reorder reports. 
o When adding a new item from the Create Purchase Order window for a SmartOrder, a message will appear in cases 

where an entered vendor item ID already exists for another item. 
o When creating a Purchase Order that is longer than what can be seen on a single page, the window will automatically 

scroll to show the next new line without requiring manual scrolling or use of Tab or arrow keys. 
o When adjusting the results-per-page view on the Purchasing Work List, the updated result display will show 

automatically. 
• Receive Purchase Orders / Entering Vendor Receipts 

o A Vendor ID is now required before you add items to a receipt, to reduce the loss of entered item information. 
o A check has been added to the Post button to verify that the Vendor ID/receipt number pair is unique. This is to 

prevent duplicate vendor receipts (and potential duplicate QOH) when multiple workstations open the same purchase 
order to receive or start a receipt at the same time. If a match is found, the receipt number is cleared, and the entered 
information is retained. To save or continue posting the receipt, a new receipt number is required.  

o An unbalanced QOH issue was addressed that occurred when receiving an item using both Buy and Sell units of 
measure (UOM) on the receipt, including instances where special pricing was also used (e.g., receiving both a box and a 
bottle, with or without use of special pricing, on one of the received UOM). 

o When a posted receipt is reopened that contains item(s) whose inventory details (e.g., buy/sell ratio or lot/exp 
tracking) were modified after the receipt was posted, the items will no longer be displayed in red text. 

o The arrow keys can once again be used to navigate the Change Price window. 
o When clicking No on the warning message when attempting to save a receipt with items that have a quantity of zero or 

less, the cursor will be placed in the qty field for the first item with the invalid quantity. Clicking Yes on the warning 
will save the receipt in its current state. 

o An issue was addressed in which the Receive Purchase Order window could lock when clicking/toggling to another 
application during receipt entry. 

o Receipt Order and Receipt Report will display modified miscellaneous item descriptions on receipt print preview in all 
access workflows (Receipt List > Print, Receipt List > View > Print). 

• Using Window > Close All will successfully close multiple inventory windows and prompt the user to save any unsaved 
changes. 

• Items at or below their reorder point will be displayed in the Transfer to list when Show only items that are low is 
selected. 

• We corrected the total cost display within the View QOH window for both lines and window, where the average cost 
calculation was impacted by QOH imbalances from receiving items at both buy and sell UOM on the same receipt. (This 
QOH calculation has also been corrected). 

• Users can successfully log into cs1loca.exe using staff IDs of four or more characters. 
• The Inventory Audit report will correctly display rows in cases where an item was received using the same receipt number 

but from different vendors. 

Laboratory 
• Lab request special actions are now separated by lab ID. 
• The lab menu listing and the lab preference setting have been 

changed from SmartLink* to Auto-billing.  
• When there are no printing preferences set for the laboratory, the 

print box for a laboratory request will no longer be displayed. See 
Activities > Lab Work > Laboratories to review and adjust 
settings for printing lab forms and labels. 

• We resolved issues with laboratory results downloading and 
posting in multiple workflows using longer staff IDs (more than 
four characters). 
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• CAN: We corrected the code display for IDEXX Reference Laboratories ordering to use a practice’s linked codes only when 
their laboratory preferences are set to not create items automatically. 

• Antech results will be downloaded for MLSD practices with valid credentials in cases where one set of practice credentials is 
invalid. 

• Heska progesterone results from Element i*+ will appear in Cornerstone on a chemistry template. 

Patient Clipboard  
• Attachments can be opened in the Patient Clipboard Preview pane by simply double-clicking the attachment. 

 
  

• A new tab for Client Communications on the Patient Clipboard, located in the client information area, will display all emails 
sent to the client from Cornerstone (invoices, estimates, documents), sourced from the existing Communications log, with 
access just a click away from the Patient Clipboard.  

 

Reports 
• A new Appointment Audit report (in the Appointment reporting group) gives you insight into appointment and block 

scheduling, modifying and deleting. Change records are time and date stamped, and the logged in user and workstation 
data are also supplied.  

• Date/time details have been added to the file export for end of month referral reports to augment existing invoice ID data. 
• Inventory reports, such as the Counts and Purchase History reports, can now be filtered to include or exclude inactive 

items.  

Client Communication tab 
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• When deleting a custom Client and Patient report, the Report Search window will be updated accordingly. 
• Pressing the Enter key when generating end of period reports will no longer cause Cornerstone to close.  
• We addressed formatting and information display issues on the Patient History Report when you include email 

communications and patients with more than one owner. 
• The Lab Request Profiles report was fixed to no longer display unnecessary blank pages. 
• The Inventory Audit report displays the correct quantities in cases where an item is received with more than one lot and/or 

expiration date for the total quantity received, as well as when an item was received using the same receipt number but 
from different vendors. 

• The Inventory Evaluation report was corrected to display all tracking inventory items, regardless of whether reorder 
information is present when sorted by vendor. 

• A print scaling error no longer occurs when saving inventory reports as a PDF file. 
• The markup value on both the Inventory Cost and Evaluation reports will consistently display two decimal places when the 

reports are previewed, printed, or saved to a CSV file. 
• The Checked In by Staff value will be displayed on the Census report for any invoice checkouts (the report is found under 

the Patient report group).  
• The Daily Invoicing and Patient Visit List Entries report now prints correctly, so that all data columns fit within the width 

of one page (the last column is no longer split with a portion of the column appearing on separate pages).  

Other enhancements and improvements  
• Callback and reminder enhancements:  

o You will be warned if a callback is open on another workstation for both reminder and lab calls. 
o You can now open other Cornerstone windows when the callback window is open. However, if you attempt to open a 

second callback window, the first callback window will be brought to the front.  
o When manually adding a reminder to a patient, only an active staff member can be entered or selected. 

• Database integrations: Steps have been taken to improve how integrated systems safely connect to your database There 
is no expected impact to your existing integrations.  

• Version upgrades: This release includes PowerBuilder and Sybase* SQL Anywhere version upgrades.  
• Improved the upgrade process by removing the application or modification of permissions to preexisting files. 
• Ending logged-in sessions: Administrator-level users can now view and end logged-in sessions 

from the User Information window, making the seat license available for another workstation. To 
access, go to File > User Information. See the F1 Help for more details.  
IMPORTANT: If the session is in use, the logged-in user will receive a database connection error 
and must close out of Cornerstone. If the login window is open, the user will receive a message 
that their username and password combination is incorrect and they should try again; however, 
they will actually need to log out of Cornerstone and log in again.  

• Practice Supplies Catalog: The IDEXX Practice Supplies Catalog can now be accessed from the 
Web Links menu. 
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• Patient Visit List window: The window will now resize to the height of the window when you select Maximize. Resizing has 
been added to these three related windows: 

PVL—height only 
Patient Diagnosis—height only 
Patient file—height and width 

• X button to close: Instances of using the X button to close Cornerstone after opening a Patient Clipboard or making 
changes to the Practice Information or Email Settings windows will close the respective windows properly.  

• Client information: The Client Title list has been updated to include the gender-neutral honorific of Mx. Entries can still be 
free-typed. 

• Daily Planner: An issue was corrected that caused the screen to ’jump’ when clicking after scrolling within the Daily 
Planner window. 

• Message Center: The scroll bar display has been corrected on the IDEXX Message Center - Appt requests window. 
• Mobile computing: A mobile computing sync issue was resolved in cases where documents with attachments were created 

while the laptop was checked out.  
• Patient Diagnosis window: The cursor focus has been reset to the next open diagnostic code ID field when you open the 

Patient Diagnosis window in all workflows and access pathways.  
• Diagnostic status: When voiding a final or a ruled-out-status diagnosis, the related tentative status is now consistently 

included. 
• Patient diagnosis: Users with a long staff ID (>4 characters) can enter their ID and successfully void a diagnosis.  
• Patient creation: An issue has been resolved that caused a record already created error when both a reminder and an 

existing rabies tag were added while creating a new patient. 
• Practice Explorer*: An issue was resolved in which Practice Explorer fields were blank when a saved report was opened. 

Note: Practice Explorer is a separately purchased module. 
• Staff List: An issue was resolved in which users who created a new staff record with only a long ID could not go back and 

update that staff record later. 
• Vital Signs: Addressed an error that could occur when using the Add Vital Signs link to access and enter vital signs from 

within a medical note. 
• Whiteboard: Blue line comments will appear correctly on the Whiteboard’s Patient Treatments window regardless of 

current time. 
• UEOM: When unattended end of month is set to run after unattended end of day, it will now run successfully, including on 

the last day of the month, whether or not transactions have been done that day. 
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