
 

On-premises and cloud-specific information is denoted by these corresponding icons: , . 

Computer hardware and software requirements  
•  For workstations and dedicated or peer-to-peer servers, we recommend a computer that: 

− Is less than 5 years old. 
− For optimal performance has at least: 

8 GB of memory (for workstations) 

 16 GB of memory (for dedicated and peer-to-peer servers) 

− Is running at least Windows* 10 Professional or later operating system. 
IMPORTANT:  
o Cornerstone* Software does not support Windows* operating systems that are no longer supported by 

Microsoft*, including Windows Server* 2003, Windows* XP, Windows* Vista, Windows* 7, Windows* Server 
2008, and Windows Server* 2008 R2. 

o IDEXX Diagnostic Imaging is offering security support of Windows 7 image-capture PCs for IDEXXCare Plus 
customers through December 31, 2022. If you are currently using Windows 7 on your image-capture PC, 
upgrade options to Windows 10 are available. For more information, contact IDEXX Diagnostic Imaging Support 
at 1-877-433-9948. 

• We recommend a monitor screen resolution setting of 1280 x 1024 or higher; settings less than 1024 x 768 are not 
recommended. For additional recommended Windows 10 settings, please see Windows 10 IDEXX Required and 
Recommended Settings. 

•  Internet access is required for both browser and application use. 

•  To use internet-based services (such as IDEXX Reference Laboratories request forms, VetConnect* PLUS, etc.) the 
server and the workstations used to access the services must be connected to the internet. 

•   For more detailed hardware and operating system information, including details on Cornerstone Cloud devices 
and on-premises Cornerstone dedicated servers and thin-client workstations, see the Hardware and Operating System 
Guidelines. 

•  IDEXX Diagnostic Imaging users: Microsoft* .NET Framework 4.0 or later is required on the server and on all 
workstations to support the Image Request and Results feature. You will be notified at the end of the Cornerstone 
installation if NET 4.0 or later is not found. 

• If you have skipped any previous upgrades, be sure to review the release notes for those upgrades, so you know about 
all the previous features and enhancements that have been incorporated into Cornerstone 9.3.   

What’s new  
To learn more about the new features and enhancements in Cornerstone 9.3:  
1. After you upgrade, press F1 or click the Help  button on the toolbar.  
2. If any windows are open in Cornerstone, click Getting Started on the Contents tab. The Welcome topic describes all 

the new features, with links to more details.  

  

  

 

 

https://www.idexx.com/files/windows-10-recommended-settings.pdf
https://www.idexx.com/files/windows-10-recommended-settings.pdf
https://www.idexx.com/en/veterinary/support/documents-resources/cornerstone-software-resources/


2  

Important notice—change to login procedure 
To protect your practice data, passwords are now stored more securely, so they can't be deciphered by someone inside or 
outside the practice. Once you upgrade to Cornerstone 9.3, your users must enter both a staff ID/name and a password 
when they log in to Cornerstone. We created a customizable team communication for you. 

You can still use nonspecific logins (such as front desk or 
staff). A staff person can select the generic name from the 
User drop-down list or enter the generic staff ID and then 
enter the password. 

Tip: Selecting Remember User will retain the name of the 
currently logged in user and display it the next time someone 
logs in at the workstation, effectively re-creating password-
only login. Note: Time Clock and Practice Explorer will always require both a user ID/name and a password (there is no 
Remember User option). 

If a user switches from a generic to a specific login, they should remember that associated default settings 
(Controls>Defaults>Staff) and security access (File>Security Setup) may be different with the specific login. An 
administrator is required for security settings. 

Staff-specific settings are available for: Patient Clipboard* tab order, toolbar display, logged-in practice (MLSD only), login 
page, default appointment suite, inventory depletion (MLSD only), and favorite documents (which can impact document 
submenus on the Patient Clipboard, if using). 

Note: If both staff and workstation settings are in place: 

• Default appointment suite, toolbar, and favorite documents will use the logged-in staff settings 
• Remember, only a Cornerstone administrator can create a new or reset an existing password. Support can assist in 

cases where the only administrator password is lost. 
• Logged-in practice and inventory depletion will use the workstation settings 

Security and default settings  
There are new security settings:  

• Dialog>Delete Client  
• Reports>Appointment – Today’s Report 
• Reports>EOD Inventory on Hand by Class, Item 
• Reports>EOD Inventory on Hand Totals 
• Reports>EOM Inventory on Hand by Class, Item 
• Reports>EOM Inventory on Hand Totals 
 

There are new and updated default settings:  

• Email settings for Gmail (Controls>Defaults>Settings>Email)  
• End of Period default reports for new inventory on hand reports (End of Period: Controls>Defaults>Practice and 

Workstation>End of Period>Daily and Monthly reports) 
• Lab pricing option (U.S. only) for IDEXX Reference Laboratories (Activities>Lab Work>Laboratories>IDEXX 

Reference Laboratory) 
• Print discount pricing per line (Controls>Defaults>Practice and Workstation>Invoice)  
• Printer Assignments (File>Printer Assignments) 

o End of period Inventory on Hand reports>End of Day and End of Month printer groups 
o Appointment – Today’s Report>General Reports printer group  

• Number of copies to print for either default or custom rabies certificates (Controls>Defaults>Practice and 
Workstation > Vaccine Tag) 

• Reason for visit referral recheck (Controls>Reason for Visit) 
• Reminder date defaults (Controls>Defaults>Practice and Workstation>Patient)  
• Report language for additional rabies certificate labels for Vaccine, Brand, Manner of Administration, Type, Doctor 

Signature, and Drug Expiration (Controls>Defaults>Practice and Workstation>Report Language) 

One setting has been deleted:  

• The password default setting (Controls>Defaults>Practice and Workstation>Passwords) is no longer available. 
For enhanced security, you must now provide both a staff ID/name and a password when you log in. 

https://www.idexx.com/files/cornerstone-9.3-login-procedure.pdf
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Featured Updates 

Pick lists: A whole new approach 

• We love pick lists, you love pick lists, everyone loves pick 
lists. And we just made them better by adding a multi-select 
function to the window: click 1, click 2, click 3, click however 
many items you want. Each selection will prompt you for any 
dispensing items, quantities (when using smart group 
functions), prescription labels, etc.  

• Simplify your group codes and reduce clicks when using 
groups. Use the Invoice Group Item Setup report (under the 
Invoice Item report group) to see what groups use the same 
pick list more than once, and then simply remove them from 
the group(s). Note: Multi-select pick lists are not available on 
classic medical notes or Patient Advisor exams.   

New document appointment and boarding bookmarks  
Simplify your patient document entry with new document bookmarks for reason for visit, appointment notes, check-in, and 
next appointment details. We added vaccine brand for rabies and also added boarding bookmarks for equipment and 
reservation notes. The new bookmarks can be found under the Patient and Boarding file descriptions: 

     
 

Discount details displayed on invoice 
In response to your requests, we’ve added a new option to clearly show the extra value received on client invoices when 
discounts are applied! Update your invoice default settings to display the details, as shown below. 

   
 

Note: We also added discount descriptions to estimates:  
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For estimate, patient visit list (PVL), document, or boarding items, right click the amount field to see the calculation 
information. 

 

New EOP reports for inventory on hand 
If you track quantity and cost with Cornerstone 
inventory, you can now use end-of-day and end-of-
month reporting to see the inventory on hand at the 
time of a specific period close. Reports are available at 
the item level (Inventory on Hand by Class, Item) or the 
classification level only (Inventory on Hand Totals).  

Note: These reports are available only for periods that 
are processed (closed) after upgrading to Cornerstone 
9.3. 

Before using the reports, be sure to assign security 
access (from the File menu). We also recommend you evaluate and, if needed, update your printer assignments (File menu) 
and end-of-period report defaults (Controls>Defaults>Practice and Workstation>End of Period).  
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Updates to the default rabies certificate 
We updated the Cornerstone rabies certificate based on your feedback. The new certificate provides improved display of 
brand, manner of administration, drug expiration date, type, and doctor signature line. Report language default settings are 
also available (Controls>Defaults>Practice and Workstation>Report Language). 

   
For convenience, the number of copies to print setting now applies to both the default and designated custom certificate  
(Controls>Defaults>Practice & Workstation>Vaccine Tag). 

 

Reminder date defaults 
A new patient default setting lets you define the default due 
date when manually entering letter and call-back reminders. 
You can choose from none, current date, or previous-line date. 
The new setting is found under Controls>Defaults>Practice 
and Workstation>Patient.  
 

Boarding and Grooming updates  
We made improvements for the display and navigation of the 
Boarding and Grooming module based on the top requests we 
received: 

• Both the client and patient Boarding tabs on the Patient 
Clipboard now populate past reservations within the last 180 
days. 

• The patient list in the Reservation Information window now 
displays patients in status order (active patients followed by 
inactive/deceased patients). Inactive- and Deceased-status 
patients are displayed in a lighter grey font with the 
corresponding (I) or (D). 

• You can now access the Patient Clipboard from the Boarding Reservations List window using the  
right-click menu. 
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Help menu link to the updated Cornerstone  
New Staff Training   
Onboarding your new team members is about to get easier. Check out the all new 
Cornerstone New Staff Training tool, located right in the Cornerstone Help menu. This 
complimentary learning tool is just two clicks away.  

General enhancements and improvements   

Appointment Scheduler 

• You can now create a new appointment by searching for and selecting either a Patient ID 
or a Client ID. The corresponding information will be filled in automatically. 

• The Today’s Appointments report (accessed from the Print button on the Schedule for 
Today window) can now be assigned to a specific printer. Go to File>Printer 
Assignment>General Reports>Appointment – Today’s report and select the printer. 
Note: This report now requires security access for new users. Existing users with access 
to the Schedule for Today window will have access automatically. 

Clients/Patients 

• Client balance transfers can be performed with either debit or credit balances. Credit transfers for a specific dollar 
amount must be entered as a negative. 

• A new tool for deleting client records (Tools>Delete client) is now available to help practices comply with local 
Personally Identifiable Information (PII) laws. IDEXX recommends you consider other data retention laws before using 
this tool. Refer to the F1 Help for additional details.  

• The 10-character client ID length has been restored.  
• We removed outdated terms and included contemporary client titles in the Client title list. 

Daily Planner 

• The patient’s inactive or deceased status now appears by the 
Patient Name field on Daily Planner tabs with specific patient 
rows. 

• The patient’s hospital status now appears on the Checked-in 
and Patient Visit List tabs. 

Email 

• New email settings for Gmail can be set under 
Controls>Defaults>Settings>E-mail. 

• The email message length was increased from 512 to 2048 characters. 
• We improved the communication (email/fax) process so the window and attached PDF are correctly displayed when 

client or patient names contain accented or special characters (#or %). 

Estimates and invoices 

• The client primary phone number and email address are now displayed on 
preview and printouts of estimates and invoices.  

• All client telephone numbers are now displayed on the Client Invoice 
window. 

• Taxes are now rounded consistently on estimates, the PVL, and invoices, so 
all tax amounts are displayed and reported consistently. 

• Discounts are now rounded consistently on invoice, estimate, PVL, and document items. 
• Pet pictures are no longer duplicated on the invoice. 

Inventory 

• Corrected the tab control and PO number fields in the Create Purchase Order window accessed from the Purchasing 
Work List. 

• Improved the process of saving long PVLs with large numbers of quantity on hand (QOH) tracking items. 
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• User interface updates were applied to inventory and communications windows.  

 
• The quantity-on-order total for the Purchasing Work List item detail is now displayed correctly. 

Medical notes and correspondence (documents) 

• The doctor signature bookmark window now displays active names in alphabetical order. 
• The laboratory results bookmark now displays the time, according to regional time display settings. 
• The rDVM bookmark uses the referral information that is set as primary vs. history. 
• Dates are no longer truncated on voided documents. 

Laboratory 

• The three-tab laboratory results now reflect the newly updated interface from VetConnect PLUS. 
• (U.S. only) There is now an IDEXX Reference Laboratories preferences option to use either your laboratory invoice 

price or the list price when marking up prices and auto-creating new lab items. 
• Updates have been made to IDEXX VetLab Station and to auto-billing to support the new ProCyte One* analyzer. 
• When viewing laboratory results from the IDEXX Message Center, the correct Patient Clipboard now opens. 

Patient Clipboard  

• You can now use the right-click menu to access the Patient Clipboard from both the Lab Requests and Results 
window and the Boarding Reservations List window. 

• The appointment history is now displayed on the client Appointments tab for the past 180 days, to align with the 
patient Appointments tab. 

• The VetConnect PLUS tab on the Patient Clipboard now reflects the newly updated interface from VetConnect PLUS. 
• (Australia) The date format has been corrected for the client last-payment date.  

Reports 

• Checked-in by information will appear on the print/preview of patient census reports. 
• The Reports menu has a new link for Enterprise Analytics. Use the link to log in and 

view your complimentary IDEXX Key Metrics Overview reports (formerly IDEXX 
Dashboard report) or to sign up for the report and to learn about other reporting tools 
with this new service. 

• The Prescription History report now offers range options for Item and Staff ID. The Item ID appears on the report 
preview, print, and save-to-file formats. Long item descriptions and prescription instructions no longer overlap on the 
report preview and printout. 

 

•  (Recommended for Cornerstone Cloud users only) An option to Batch print is now available to reduce the 
number of print jobs sent to the cloud document printer when you print monthly invoices and statements. Note: The 
number of accounts per batch is set to 200 accounts per file. Customer support can adjust this setting, if needed. 
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Other enhancements and improvements 

• New staff IDs can now be up to 6 characters long. Note: Current staff IDS cannot be modified. 
• Names in the Staff drop-down list on the Census List (F3), the Physical Exam window, and the Log In window are 

now displayed as staff name (staff ID), as seen on the Lab Requests and Results window and the Image Requests 
and Results window. 

 
• Appointment, client, patient, and compliance alerts are displayed consistently from all check-in workflows, based on 

client and patient alert settings. 
• When defining the primary reason for visit (Controls>Reason for Visit), you 

can now select a Referral recheck check box. The box can be checked by 
default at patient check-in to improve tracking and reporting of new and 
recheck referral cases.   

• The cursor focus has been corrected in the weight field on the check-in 
window in specific workflows to reduce entry errors. 

• The Web Links menu includes new selections for SmartFlow, remote access, 
and Pet Health Network* Pro texting  

• The messaging related to the File menu and exceeding the seat license count 
has been modified for clarity. 

• The invoice billing message has been reformatted (with left-justified text and smaller margins) to improve readability 
and display more text.  

• The client description now prints correctly on prescription refills and renewals in cases where the hospital description 
was modified since the original prescription.  

• Made improvements to unattended end of day processing time. 
• The database will remain locked for posting transactions between unattended end of day and unattended end of 

month (when set to run immediately following unattended end of day).  
• We have standardized the rounding method used for item pricing entry from SmartFlow to PVL. 
• The outdated Hills Feeding Guide menus and options have been removed because no further updates will be 

available. 
• The Data Services Agreement has been removed from the Tools menu. For practices wanting to sign up for the Key 

Metrics Overview, you can sign up and view your practice report under Reports>Enterprise Analytics. 
• An issue has been resolved for certain workflows that inhibited the completion of subsequent Whiteboard treatments 

when processing multiple treatments. 
• A “not responding” message no longer appears when you enter a vaccine tag number in cases where there are 

more than 32,767 matches.  
• The PVL will retain changes made to the item order when saved. 
• To remove an existing password in the Security Setup window, click Clear current password.  

Note: An administrator password is required to access security settings. 
• Accessing CareCredit* will open the CareCredit portal directly. Cornerstone client information will not be passed to 

the portal at this time. 

 
 

 
idexx.com/cornerstone  

© 2021 IDEXX Laboratories, Inc. All rights reserved. • 06-0016317-00  
*Cornerstone, Patient Clipboard, Pet Health Network, ProCyte One, and VetConnect are trademarks or registered trademarks of IDEXX Laboratories, Inc. or its 
affiliates in the United States and/or other countries.   
All other product and company names and logos are trademarks or registered trademarks of their respective holders.  
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